diff options
author | Ralph Amissah <ralph@amissah.com> | 2011-10-03 21:20:32 -0400 |
---|---|---|
committer | Ralph Amissah <ralph@amissah.com> | 2011-10-03 21:20:32 -0400 |
commit | 34d683d8857adab360c75edffe5a1af410c3a373 (patch) | |
tree | c85e5ad32a6e54431d36ad99f7f4b93544bdfd6b /bin/sisu3 | |
parent | debian/changelog (3.0.19-1) (diff) | |
parent | v2 v3: documenation, html, man2html (sisu.1) (diff) |
Merge commit 'sisu_3.1.0' into debian/sid
Diffstat (limited to 'bin/sisu3')
-rw-r--r-- | bin/sisu3 | 12 |
1 files changed, 8 insertions, 4 deletions
@@ -29,8 +29,12 @@ current version #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']} WOK end end + def check_sisu_legacy_ruby_version? + rbv_sisu_legacy='1.9.2' #'1.8.7' + ruby_version_ok?(rbv_sisu_legacy) + end def check_sisu_stable_ruby_version? - rbv_sisu_stable='1.8.7' + rbv_sisu_stable='1.9.2' ruby_version_ok?(rbv_sisu_stable) end def check_sisu_dev_ruby_version? @@ -42,16 +46,16 @@ WOK argv=$* SiSU_version_dir=case argv.inspect when /--v2/ - check_sisu_stable_ruby_version? + check_sisu_legacy_ruby_version? 'v2' when /--v3/ - check_sisu_dev_ruby_version? + check_sisu_stable_ruby_version? 'v3' when /--dev/ check_sisu_dev_ruby_version? 'v3' else - check_sisu_dev_ruby_version? + check_sisu_stable_ruby_version? 'v3' end SiSU_lib="sisu/#{SiSU_version_dir}" |