aboutsummaryrefslogtreecommitdiffhomepage
path: root/.envrc
diff options
context:
space:
mode:
Diffstat (limited to '.envrc')
-rw-r--r--.envrc16
1 files changed, 3 insertions, 13 deletions
diff --git a/.envrc b/.envrc
index 3c334084..6ad5fe23 100644
--- a/.envrc
+++ b/.envrc
@@ -1,16 +1,6 @@
-use flake .
-#use flake .#default
-NIX_ENFORCE_PURITY=1
-NixDirEnvVersion="2.2.1"
-if ! has nix_direnv_version || ! nix_direnv_version ${NixDirEnvVersion}; then
-# - https://github.com/nix-community/nix-direnv
-# source_url "https://raw.githubusercontent.com/nix-community/nix-direnv/${NixDirEnvVersion}/direnvrc" "sha256-0000000000000000000000000000000000000000000="
- source_url "https://raw.githubusercontent.com/nix-community/nix-direnv/${NixDirEnvVersion}/direnvrc" "sha256-zelF0vLbEl5uaqrfIzbgNzJWGmLzCmYAkInj/LNxvKs="
-fi
-watch_file flake.lock
-watch_file flake.nix
if [ -f .envrc-local ]; then
source_env_if_exists .envrc-local || source .envrc-local
fi
-PATH_add result/bin
-#nix flake update && nix flake check --show-trace && nix flake show
+if [ -f .envrc-nix ]; then
+ source_env_if_exists .envrc-nix || source .envrc-nix
+fi