aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix54
1 files changed, 27 insertions, 27 deletions
diff --git a/shell.nix b/shell.nix
index 9f689127..ec794cda 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,28 +1,28 @@
-#!/usr/bin/env -S nix-shell --pure
-{ pkgs ? import <nixpkgs> {} }:
+#!/usr/bin/env -S nix-shell --impure
+#!nix-shell -i bash
+{pkgs ? import <nixpkgs> {}}:
with pkgs;
-mkShell {
- buildInputs = [
- ruby_3_1
- rubyPackages_3_1.rake
- rubyPackages_3_1.sqlite3
- rubyPackages_3_1.thor
- sqlite
- unzip
- xz
- zip
- openssl
- #texlive-combined-full
- nixFlakes
- validatePkgConfig
- jq
- git
- starship
- ];
- shellHook = ''
- if [[ -e ".envrc" ]]; then
- source .envrc
- fi
- eval "$(starship init bash)"
- '';
-}
+ mkShell {
+ buildInputs = [
+ ruby_3_3
+ rubyPackages_3_3.rake
+ rubyPackages_3_3.sqlite3
+ rubyPackages_3_3.thor
+ sqlite
+ graphicsmagick
+ unzip
+ xz
+ zip
+ openssl
+ #texlive-combined-full
+ nixFlakes
+ validatePkgConfig
+ nix-output-monitor
+ nix-tree
+ jq
+ git
+ #starship
+ ];
+ shellHook = ''
+ '';
+ }