summaryrefslogtreecommitdiffhomepage
path: root/nix-overlays/dtools/package.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2025-03-22 12:29:04 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2025-03-22 12:57:03 -0400
commit39b16223937fa3fc8da80495a25d7397712b8bae (patch)
treedff0c37c726c59140abf792a11c3892ff3a2d9c9 /nix-overlays/dtools/package.nix
parentldc-1.40.1 (based on D 2.110.0) - overlay (diff)
overlay updates (dub-1.39.0, dtools-2.110.0)
Diffstat (limited to 'nix-overlays/dtools/package.nix')
-rw-r--r--nix-overlays/dtools/package.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/nix-overlays/dtools/package.nix b/nix-overlays/dtools/package.nix
new file mode 100644
index 0000000..2e72b44
--- /dev/null
+++ b/nix-overlays/dtools/package.nix
@@ -0,0 +1,49 @@
+{
+ lib,
+ stdenv,
+ fetchFromGitHub,
+ ldc,
+ curl,
+}:
+
+stdenv.mkDerivation (finalAttrs: {
+ pname = "dtools";
+ version = "2.110.0";
+
+ src = fetchFromGitHub {
+ owner = "dlang";
+ repo = "tools";
+ rev = "v${finalAttrs.version}";
+ hash = "sha256-xMEHnrstL5hAkhp8+/z1I2KZWZ7eztWZnUGLTKCfbBI=";
+ name = "dtools";
+ };
+
+ patches = [
+ # Disable failing tests
+ ./disabled-tests.diff
+ # Fix LDC arm64 build
+ ./fix-ldc-arm64.diff
+ ];
+
+ nativeBuildInputs = [ ldc ];
+ buildInputs = [ curl ];
+
+ makeFlags = [
+ "CC=${stdenv.cc}/bin/cc"
+ "DMD=${ldc.out}/bin/ldmd2"
+ "INSTALL_DIR=$(out)"
+ ];
+
+ enableParallelBuilding = true;
+
+ doCheck = true;
+ checkTarget = "test_rdmd";
+
+ meta = with lib; {
+ description = "Ancillary tools for the D programming language";
+ homepage = "https://github.com/dlang/tools";
+ license = licenses.boost;
+ maintainers = with maintainers; [ jtbx ];
+ platforms = platforms.unix;
+ };
+})