summaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2024-04-24 12:11:50 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2024-04-24 12:11:50 -0400
commit7591439b407b39ecfc37b667bc3d54192aa4b9ef (patch)
treee95e3977686f54735fcd8707da815ead918e703d /shell.nix
ldc-1.37.0 ... dub 1.36.0
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100755
index 0000000..b9015da
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,44 @@
+#!/usr/bin/env -S nix-shell --pure
+#!nix-shell -i bash
+{pkgs-nix ? import <nixpkgs> {}}:
+with pkgs-nix;
+ mkShell {
+ buildInputs = [
+ # ❯❯❯ nix_related
+ #nix
+ direnv
+ nixVersions.unstable
+ nix-prefetch-git
+ validatePkgConfig
+ nix-output-monitor
+ #nix-tree
+ #nvd
+ jq #gx
+ #alejandra
+ git
+ # ❯❯❯ dev
+ gnumake
+ ps
+ # ❯❯❯ d_build_related
+ # ❯❯ compiler
+ #dmd
+ #ldc
+ #rund
+ # ❯❯ package manager
+ #dub
+ # ❯❯ linker
+ #lld
+ #mold
+ # ❯❯ builder
+ #ninja
+ #meson
+ # ❯❯ tools
+ #dub
+ #dtools
+ # ❯❯❯ test
+ #tilix
+ #gtkd
+ ];
+ shellHook = ''
+ '';
+ }