aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2025-03-07 19:25:02 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2025-03-07 19:25:02 -0500
commitdaae25c872dbad11a281ccaa9593ad72f83727b5 (patch)
tree8e7c2cdef9c60dcaef5642d8b23a000af0a47092 /flake.nix
parentorg, reorganize version info (diff)
spine sync, 0.18.0HEADmain
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 16 insertions, 8 deletions
diff --git a/flake.nix b/flake.nix
index c26bdef..0679df9 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,12 +1,16 @@
{
description = "spine (sisu like parser & document generator) made available to process markup samples";
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
- #inputs.flake-utils.url = "github:numtide/flake-utils";
inputs.spine = {
url = "git://git.sisudoc.org/software/sisudoc-spine";
inputs.nixpkgs.follows = "nixpkgs";
flake = true;
};
+ #inputs.spine-search-cgi = { # issue, to make usable needs local configuration on build, so, not practical to implement like so
+ # url = "git://git.sisudoc.org/software/sisudoc-spine-search-cgi";
+ # inputs.nixpkgs.follows = "nixpkgs";
+ # flake = true;
+ #};
inputs.sisudoc-d-overlay = {
url = "git://git.sisudoc.org/package/dlang-nix-overlays-and-flake";
inputs.nixpkgs.follows = "nixpkgs";
@@ -15,12 +19,12 @@
outputs = {
self,
nixpkgs,
- #flake-utils,
spine,
+ #spine-search-cgi,
sisudoc-d-overlay,
...
}@inputs: let
- version = "0.17.0";
+ version = "0.18.0";
shell = ./shell.nix;
devEnv = ./nixDevEnv.sh;
supportedSystems = ["x86_64-linux"]; # [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
@@ -35,6 +39,10 @@
spine-nixpkgs-ldc = spine.packages.${system}.spine-nixpkgs-ldc;
spine-overlay-dmd = spine.packages.${system}.spine-overlay-dmd;
spine-overlay-ldc = spine.packages.${system}.spine-overlay-ldc;
+ #spine-search-cgi-nixpkgs-dmd = spine-search-cgi.packages.${system}.spine-search-nixpkgs-dmd; # issue, to make usable needs local configuration on build
+ #spine-search-cgi-nixpkgs-ldc = spine-search-cgi.packages.${system}.spine-search-nixpkgs-ldc; # issue, to make usable needs local configuration on build
+ #spine-search-cgi-overlay-dmd = spine-search-cgi.packages.${system}.spine-search-overlay-dmd; # issue, to make usable needs local configuration on build
+ #spine-search-cgi-overlay-ldc = spine-search-cgi.packages.${system}.spine-search-overlay-ldc; # issue, to make usable needs local configuration on build
#vendorSha256 = "sha256-0Q00000000000000000000000000000000000000000=";
});
apps = forAllSystems (system: {
@@ -71,7 +79,7 @@
dsh-overlay-ldc = sisudoc-d-overlay.devShells.${system}.dsh-overlay-ldc-dub;
dsh-nixpkgs-ldc = sisudoc-d-overlay.devShells.${system}.dsh-nixpkgs-ldc-dub;
dsh-epub = mkShell {
- name = "spine-0.17.0 dev shell for epub output";
+ name = "spine-0.18.0 dev shell for epub output";
inherit shell;
inherit devEnv;
packages = [
@@ -99,7 +107,7 @@
inherit shellHook;
};
dsh-html = mkShell {
- name = "spine-0.17.0 dev shell for html output";
+ name = "spine-0.18.0 dev shell for html output";
inherit shell;
inherit devEnv;
packages = [
@@ -119,7 +127,7 @@
inherit shellHook;
};
dsh-latex-pdf = mkShell {
- name = "spine-0.17.0 dev shell for latex & pdf output";
+ name = "spine-0.18.0 dev shell for latex & pdf output";
inherit shell;
inherit devEnv;
packages = [
@@ -135,7 +143,7 @@
inherit shellHook;
};
dsh-sqlite = mkShell {
- name = "spine-0.17.0 dev shell for sqlite3 output";
+ name = "spine-0.18.0 dev shell for sqlite3 output";
inherit shell;
inherit devEnv;
packages = [
@@ -148,7 +156,7 @@
inherit shellHook;
};
dsh-i18n = mkShell {
- name = "spine-0.17.0 dev shell for internationalization, po4a";
+ name = "spine-0.18.0 dev shell for internationalization, po4a";
inherit shell;
inherit devEnv;
packages = [