summaryrefslogtreecommitdiffhomepage
path: root/derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'derivation.nix')
-rw-r--r--derivation.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/derivation.nix b/derivation.nix
index 495cefd..efe8ebf 100644
--- a/derivation.nix
+++ b/derivation.nix
@@ -48,7 +48,7 @@ with (
buildPhase = ''
runHook preBuild
HOME="$PWD"
- DFLAGS="-O2 -inline"
+ #DFLAGS="-O2 -inline"
for DC_ in dmd ldmd2 gdmd; do
echo "- check for D compiler $DC_"
DC=$(type -P $DC_ || echo "")
@@ -92,13 +92,14 @@ with (
}
);
mkDubDerivation rec {
- name = "spine-search-${version}";
+ name = "spine-search-0.18.0";
+ #name = "spine-search-${version}";
src = ./.;
buildInputs = [
pkgs.sqlite
(
with pkgs-nix; [
- nixVersions.nix_2_21 #nixVersions.latest #nixVersions.git
+ nixVersions.latest #nixVersions.latest #nixVersions.git
## package manager
dub
## compiler
@@ -110,7 +111,7 @@ with (
];
meta = with pkgs-nix.lib; {
pname = "spine-search";
- version = "0.17.0";
+ version = "0.18.0";
homepage = "https://sisudoc.org";
description = "cgi sqlite search form for document object search";
longDescription = ''